ERROR: dependency ‘PythonEmbedInR’ is not available for package ‘synapser’

Description

Our collaborator was not able to install synapser due to this error with PythonEmbedInR.

Environment

None

Activity

Show:
Bruce Hoff
December 20, 2019, 5:21 PM
Edited

It works on my Mac running R v. 3.4. I upgraded to 3.6 and verified it works. can you please find out what kind of machine and what version of R the collaborator is using?

Kelsey Montgomery
December 23, 2019, 5:35 PM

 

 

Bruce Hoff
December 23, 2019, 6:41 PM

I am not sure why your colleague's MacOS installation of R is trying to install the package as source rather than binary. I have two requests for them:
(1) Please return the result of running this R command:
> getOption("pkgType")
(2) Try 'forcing' the use of the binary version of the package:
> install.packages("synapser", repos=c("http://ran.synapse.org", "http://cran.fhcrc.org"), type="binary")

Assignee

Unassigned

Reporter

Kelsey Montgomery

Labels

None

Validator

Bruce Hoff

Development Area

None

Release Version History

None

Priority

Major
Configure