synapser and reticulate don't play nicely

Description

There are two errors I get when trying to use both synapser and reticulate in the same R program.

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 Restarting R session... > reticulate::import("os") Module(os) > library(synapser) Traceback (most recent call last): File "<string>", line 1, in <module> File "/Library/Frameworks/R.framework/Versions/3.4/Resources/library/PythonEmbedInR/lib/python3.5/site-packages/pip/__init__.py", line 21, in <module> from pip._vendor.requests.packages.urllib3.exceptions import DependencyWarning File "/Library/Frameworks/R.framework/Versions/3.4/Resources/library/PythonEmbedInR/lib/python3.5/site-packages/pip/_vendor/requests/__init__.py", line 62, in <module> from .packages.urllib3.exceptions import DependencyWarning File "/Library/Frameworks/R.framework/Versions/3.4/Resources/library/PythonEmbedInR/lib/python3.5/site-packages/pip/_vendor/requests/packages/__init__.py", line 27, in <module> from . import urllib3 File "/Library/Frameworks/R.framework/Versions/3.4/Resources/library/PythonEmbedInR/lib/python3.5/site-packages/pip/_vendor/requests/packages/urllib3/__init__.py", line 8, in <module> from .connectionpool import ( File "/Library/Frameworks/R.framework/Versions/3.4/Resources/library/PythonEmbedInR/lib/python3.5/site-packages/pip/_vendor/requests/packages/urllib3/connectionpool.py", line 7, in <module> from socket import error as SocketError, timeout as SocketTimeout File "/Library/Frameworks/R.framework/Versions/3.4/Resources/library/PythonEmbedInR/lib/python3.5/socket.py", line 49, in <module> import _socket SystemError : initialization of _socket failed without raising an exception Error: package or namespace load failed for ‘synapser’: .onLoad failed in loadNamespace() for 'PythonEmbedInR', details: call: value[[3L]](cond) error: ERROR: Missing system dependencies. Please make sure that your machine has the required dependencies listed in the SystemRequirements field of the DESCRIPTION file: https://github.com/Sage-Bionetworks/PythonEmbedInR/blob/master/DESCRIPTION

And after restarting R once again...

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 Restarting R session... > library(synapser) TERMS OF USE NOTICE: When using Synapse, remember that the terms and conditions of use require that you: 1) Attribute data contributors when discussing these data or results from these data. 2) Not discriminate, identify, or recontact individuals or groups represented by the data. 3) Use and contribute only data de-identified to HIPAA standards. 4) Redistribute data only under these same terms of use. > reticulate::import("os") Traceback (most recent call last): File "/Library/Frameworks/R.framework/Versions/3.4/Resources/library/synapser/lib/python3.5/site-packages/site.py", line 73, in <module> __boot() File "/Library/Frameworks/R.framework/Versions/3.4/Resources/library/synapser/lib/python3.5/site-packages/site.py", line 3, in __boot import os ImportError: No module named os Error in python_config(python_version, required_module, python_versions) : Error 1 occurred running /Users/psnyder/.virtualenvs/r-reticulate/bin/python In addition: Warning message: running command ''/Users/psnyder/.virtualenvs/r-reticulate/bin/python' "/Library/Frameworks/R.framework/Versions/3.4/Resources/library/reticulate/config/config.py"' had status 1

Is anyone able to reproduce or is this something specific to how I've installed synapser/reticulate?

Environment

None

Status

Assignee

Unassigned

Reporter

Phil Snyder

Validator

Kenneth Daily

Release Version History

None

Fix versions

Priority

Major
Configure