synapser breaks argparse library

Description

When you do this, argparse library in R works:

1 2 3 library(argparse) parser <- ArgumentParser() library(synapser)

But when you do this... It fails.

1 2 3 4 5 6 7 8 9 library(argparse) library(synapser) parser <- ArgumentParser() Error in find_python_cmd(required_modules = c("argparse", "json | simplejson")) : Couldn't find a sufficient Python binary. If you haven't installed the Python dependency yet please do so. If you have but it isn't on the system path (as is default on Windows) please add it to path or set options('python_cmd'='/path/to/binary') or set the PYTHON, PYTHON2, or PYTHON3 environmental variables. Python must have access to the modules: argparse, json | simplejson In addition: Warning message: In sprintf("python executable %s either is not installed,", python_cmd) : restarting interrupted promise evaluation

Environment

None

Status

Assignee

Unassigned

Reporter

Thomas Yu

Validator

Thomas Yu

Release Version History

None

Fix versions

Priority

Major
Configure