issue with 'deprecated' package version dependency

Environment

bash-4.2# cat /etc/os-release
NAME="Amazon Linux AMI"
VERSION="2017.03"
ID="amzn"
ID_LIKE="rhel fedora"
VERSION_ID="2017.03"
PRETTY_NAME="Amazon Linux AMI 2017.03"
ANSI_COLOR="0;33"
CPE_NAME="cpe:/o:amazon:linux:2017.03:ga"
HOME_URL="http://aws.amazon.com/amazon-linux-ami/"

Activity

Show:
Kenneth Daily
October 11, 2019, 11:37 PM

Probably not. I'm going to close this for now unless it reoccurs for someone else.

Kimyen Truong
June 6, 2019, 11:50 PM

, the Synapse Python client lock down dependency deprecated to 1.2.4. This is to prevent breaking changes in newer version of deprecated to effect the performance of the Synapse Python client.

It looks like your package only requires deprecated v 1.2.4. But you had deprecated v 1.2.5 installed. Is there any reason you need deprecated v 1.2.5?

 

Kenneth Daily
June 6, 2019, 11:08 PM

I am installing a package of my own which depends on Synapse. In the 'setup.py' I require deprecated>=1.2.4.

https://github.com/bsmn/ndasynapse/blob/master/setup.py#L17

Won't Fix

Assignee

Unassigned

Reporter

Kenneth Daily

Labels

None

Validator

Bruce Hoff

Development Area

None

Release Version History

None

Slack Channel

None

Affects versions

Priority

Major