Uploaded image for project: 'Synapse Python Client'
  1. SYNPY-849

Add deprecation warning that isn't filtered by Python

    Details

    • Type: New Feature
    • Status: Closed (View workflow)
    • Priority: Major
    • Resolution: Fixed
    • Affects versions: None
    • Fix versions: py-1.9.1
    • Components: None
    • Labels:

      Description

      Example using pandas:

      In [13]: import pandas as pd
      
      In [14]: temp = pd.DataFrame()
      
      In [15]: temp.ix()
      /Library/Frameworks/Python.framework/Versions/3.6/bin/ipython:1: DeprecationWarning: 
      .ix is deprecated. Please use
      .loc for label based indexing or
      .iloc for positional indexing
      
      See the documentation here:
      http://pandas.pydata.org/pandas-docs/stable/indexing.html#ix-indexer-is-deprecated
        #!/Library/Frameworks/Python.framework/Versions/3.6/bin/python3.6
      Out[15]: <pandas.core.indexing._IXIndexer at 0x11365cef8>
      
      

      So everytime I use the ".ix()" command, there is a "DeprecationWarning" that pops up which also provides me to functions to use.

        Designs

          Attachments

            Activity

              People

              • Assignee:
                thomas.yu Thomas Yu
                Reporter:
                thomas.yu Thomas Yu
                Validator:
                Ziming Dong
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: