Restrict version of dbus-python in Travis build

Description

Travis Builds are showing error because the dbus-python library updated on May 4, 2018 and has a version requirement of dbus > 1.8 on the system. Unfortunately, Travis is still on Ubuntu 14 (Trusty) and only has dbus up to 1.6.8. We need to explicitly install dbus-python 1.2.4 to make the builds pass

Environment

None

Activity

Show:
Ziming Dong
June 5, 2018, 8:19 PM

This is fine to close. This issue was made to fix a very specific dependency problem in our Travis builds.

Meredith Slota
June 1, 2018, 8:40 PM

Is this ok to close out or is there still work to be done here?

Ziming Dong
May 7, 2018, 10:01 PM

I've created a new Issue in to use Docker to avoid dependency problems like this in the future. This issue needed to be fixed quickly so our users don't think the newly released 1.8.0 on master branch is broken when it is actually not.

Bruce Hoff
May 7, 2018, 9:53 PM

It seems that one way to do this is to override the default Trusty Docker container:
https://docs.travis-ci.com/user/docker/

Fixed

Assignee

Ziming Dong

Reporter

Ziming Dong

Labels

None

Validator

Larsson Omberg

Development Area

None

Release Version History

None

Slack Channel

None

Fix versions

Priority

Major