Restrict version of dbus-python in Travis build
Travis Builds are showing error because the dbus-python library updated on May 4, 2018 and has a version requirement of dbus > 1.8 on the system. Unfortunately, Travis is still on Ubuntu 14 (Trusty) and only has dbus up to 1.6.8. We need to explicitly install dbus-python 1.2.4 to make the builds pass
This is fine to close. This issue was made to fix a very specific dependency problem in our Travis builds.
Is this ok to close out or is there still work to be done here?
I've created a new Issue in to use Docker to avoid dependency problems like this in the future. This issue needed to be fixed quickly so our users don't think the newly released 1.8.0 on master branch is broken when it is actually not.