Upgrade/fix Pandas dependency


numpy version 1.19.0 was released on 6/20, but the version of pandas we pin as an extra dependency of synapseclient (0.25) cannot compile against it, as a referenced macro was removed resulting in the following error when installing synapseclient when these dependencies are compiled from source:

This results because our pinned extra dependency pandas==0.25 in turn declares its numpy dependency as >= which includes the latest version released on 6/20 against which it is not actually compilable.

This effects anyone running python 3.8 specifically that installs synapseclient with its pandas extra dependency, e.g.

Python 3.6 and 3.7 are not as directly affected because pre-compiled wheel installs of pandas are available for pandas 0.25 for those python versions.

It also doesn't affect anyone who installs pandas and synapseclient separately, e.g.

because that will result in a current version of pandas anyway that can compile against the more recent numpy.


python 3.8


Jordan Kiang
June 23, 2020, 3:56 AM

Proposing to fix this by unpinning our dependency versions rather than simply upgrading our pinned version as described in

Jordan Kiang
June 24, 2020, 10:29 PM

PR merged, dependencies except keyring upgraded with floating versions.

Keyring will be upgraded separately as per SYNPY-1077. Current unit/integration tests may not adequately account for the upgrade paths and that will need to be looked at separately.

Jordan Kiang
July 9, 2020, 6:41 PM

This had been causing broken builds on Mac + Python 3.8 as described above. https://travis-ci.com/github/jkiang13/synapsePythonClient/jobs/352434929

This change fixed this issue as validated in successful Travis builds in this environment, e.g.


Jordan Kiang


Jordan Kiang




Bruce Hoff

Development Area

Synapse Core Infrastructure

Release Version History


Fix versions

Affects versions